Faculty.uvu.edu Outage

Incident Report for Utah Valley University

Resolved

The faculty.uvu.edu outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Nov 21, 2023 - 09:45 MST

Update

The vendor is aware of this issue and is working to resolve it. Updates will be provided as we learn more.
Posted Nov 20, 2023 - 15:34 MST

Identified

We have identified an outage affecting faculty.uvu.edu. Updates will be provided as we learn more.
Posted Nov 20, 2023 - 12:10 MST
This incident affected: General IT Services.