Partial Teams Voice Phone Outage

Incident Report for Utah Valley University

Resolved

The partial Teams Voice outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Mar 03, 2025 - 16:18 MST

Monitoring

A fix has been applied and Teams Voice phone calls should be available. We will continue to monitor it closely.
Posted Mar 03, 2025 - 14:30 MST

Investigating

We are investigating reports of a Teams Voice phone outage. Updates will be provided as we learn more.
Posted Mar 03, 2025 - 11:58 MST
This incident affected: Email, Calendar, & Collaboration (Telephones).