Get email notifications whenever Utah Valley University creates, updates or resolves an incident.
Get text message notifications whenever Utah Valley University creates or resolves an incident.
Get webhook notifications whenever Utah Valley University creates an incident, updates an incident, resolves an incident or changes a component status.
The myUVU outage affecting users ability to email via myUVU has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Apr 09, 2026 - 16:19 MDT
Monitoring
A fix has been applied and emails sent via myUVU to advisors and others are now correctly being sent to recipients. We will continue to monitor myUVU closely.
Posted Apr 09, 2026 - 12:35 MDT
Update
We are continuing to investigate this issue.
Posted Apr 09, 2026 - 11:22 MDT
Investigating
We are investigating reports of a myUVU outage affecting students ability to message advisors via the "Send a Message" button in myUVU. Advisors may also be unable to receive messages from the Message Advisor link at this time. Updates will be provided as we learn more.