myUVU Registration and Academics page issues
Incident Report for Utah Valley University
Resolved
The myUVU Registration and Academics page blurring issue has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Aug 23, 2021 - 18:29 MDT
Monitoring
A fix has been applied. The Registration and Academics myUVU page should be visible to users. We will continue to monitor it closely.
Posted Aug 23, 2021 - 13:39 MDT
Investigating
We are investigating reports of issues accessing the Registration and Academics page in myUVU. Updates will be provided as we learn more.
Posted Aug 23, 2021 - 13:11 MDT
This incident affected: myUVU Services (myUVU Student Services).