Partial MyUVU Outage
Incident Report for Utah Valley University
Resolved
The myUVU outage affecting students has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Oct 21, 2022 - 11:21 MDT
Monitoring
A fix has been applied and myUVU semester tabs should be available to students. We will continue to monitor it closely.
Posted Oct 21, 2022 - 10:13 MDT
Identified
We have identified a partial myUVU outage affecting all students. Updates will be provided as we learn more.
Posted Oct 21, 2022 - 10:04 MDT
Investigating
We are investigating reports of a myUVU outage. Students are unable to view the semester tabs in myUVU. Updates will be provided as we learn more.
Posted Oct 21, 2022 - 09:18 MDT
This incident affected: myUVU Services (myUVU Student Services).