Leave of Absence/Deferment Form Outage

Incident Report for Utah Valley University

Monitoring

A fix has been applied and the Leave of Absence/Deferment form should be available for all users. We will continue to monitor it closely.
Posted Jul 23, 2026 - 15:16 MDT

Identified

We have identified a Leave of Absence/Deferment form outage affecting all students attempting to access the form. Updates will be provided as we learn more.
Posted Jul 23, 2026 - 12:15 MDT
This incident affects: myUVU Services (myUVU Student Services).