Bursar's Office Calls Disconnecting

Incident Report for Utah Valley University

Resolved

The outage affecting calls to the bursar's office has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Jul 23, 2025 - 14:09 MDT

Update

Some calls to the bursar's office may still not connect properly. The issue appears to be intermittent and the investigation is ongoing. Additional updates will be provided as we learn more.
Posted Jul 22, 2025 - 08:32 MDT

Investigating

We are investigating reports of calls disconnecting when calling the bursar's office. Updates will be provided as we learn more.
Posted Jul 21, 2025 - 15:56 MDT
This incident affected: Email, Calendar, & Collaboration (Telephones).