Get email notifications whenever Utah Valley University creates, updates or resolves an incident.
Get text message notifications whenever Utah Valley University creates or resolves an incident.
Get webhook notifications whenever Utah Valley University creates an incident, updates an incident, resolves an incident or changes a component status.
The outage impacting McGraw Hill Connect access via Canvas has been resolved. Please contact the Service Desk should you encounter further issues.
Posted Feb 10, 2026 - 16:22 MST
Identified
Third party content provider McGraw Hill <is reporting an issue preventing students from accessing some content through Canvas. More information will be provided as we learn more.
Posted Feb 10, 2026 - 14:39 MST
Investigating
We are investigating an issue that is preventing students from accessing McGraw Hill Connect via Canvas. More information will be provided as we learn more.
Posted Feb 10, 2026 - 14:28 MST
This incident affected: Teaching, Learning, & Classrooms (Canvas).