Loss of power to Wee Care center and other building on East campus

Incident Report for Utah Valley University

Resolved

The power outage affecting the Wee Care center and adjacent buildings has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Jul 17, 2025 - 11:30 MDT

Identified

We have identified a loss of power to the Wee Care center and multiple other buildings on the East side of UVU's main campus related to ongoing construction. The Wee Care center is closed. Additional details will be provided as we learn more.
Posted Jul 16, 2025 - 11:59 MDT
This incident affected: Network & Wireless (Wireless Network, Wired Network) and General IT Services.