Partial myUVU Student outage for off-campus users

Incident Report for Utah Valley University

Resolved

The myUVU Student partial outage impacting off-campus users has been resolved. Please contact the Service Desk if you experience any further issues.
Posted Jun 13, 2025 - 14:24 MDT

Monitoring

A fix has been applied and myUVU Student should be fully functional for all users. We will continue to monitor myUVU Student closely.
Posted Jun 13, 2025 - 10:39 MDT

Investigating

We are investigating reports of a partial myUVU Student outage for users that are off-campus. Details will be provided as we learn more.
Posted Jun 13, 2025 - 10:09 MDT
This incident affected: myUVU Services (myUVU Student Services).