Authentication issue with Tuition Payment Plus
Incident Report for Utah Valley University
Resolved
This has been resolved with a direct link.
Posted Mar 15, 2020 - 10:16 MDT
Monitoring
A workaround for accessing Tuition Payment PLUS has been identified. Users experiencing this issue should visit https://www.uvu.edu/cashier/plus.html for a direct link to Tuition Payment PLUS. Please contact the Service Desk if you continue to encounter issues.
Posted Mar 14, 2020 - 11:05 MDT
Identified
The issue has been identified and we are working on a short term workaround.
Posted Mar 14, 2020 - 10:43 MDT
Investigating
Some users attempting to access Tuition Payment PLUS are presented with an authorized users login page that does not accept UVIDs and passwords. I.T. is looking into this issue.
Posted Mar 14, 2020 - 10:20 MDT
This incident affected: myUVU Services (myUVU General Services).