Get email notifications whenever Utah Valley University creates, updates or resolves an incident.
Get text message notifications whenever Utah Valley University creates or resolves an incident.
Get webhook notifications whenever Utah Valley University creates an incident, updates an incident, resolves an incident or changes a component status.
The partial cloud vendor outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Oct 31, 2025 - 09:26 MDT
Monitoring
A fix has been applied and all affected services should be available to all users. We will continue to monitor it closely.
Posted Oct 30, 2025 - 12:06 MDT
Update
Update: Campus call centers are available to receive calls again. Restoration of other affected services is ongoing. Updates will be provided as more services become available.
Posted Oct 29, 2025 - 15:06 MDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 29, 2025 - 12:15 MDT
Update
Update: the Service Desk has some services restored, such as password resets and authentication method modifications. Email services and calls are still affected.
Posted Oct 29, 2025 - 12:08 MDT
Update
Update: the Service Desk and Financial Aid office are unable to receive calls right now. If you need to contact either department, please contact them online through a ticket or a chat through https://www.uvu.edu/servicedesk/
Posted Oct 29, 2025 - 10:58 MDT
Identified
We have identified a partial cloud vendor outage affecting password resets, testing services, campus call centers, and other campus IT services. Updates will be provided as we learn more.
Posted Oct 29, 2025 - 10:46 MDT
This incident affected: myUVU Services (myUVU Student Services, myUVU Employee Services) and General IT Services.