TouchNet Outage

Incident Report for Utah Valley University

Resolved

The TouchNet outage has been resolved. Please contact the Service Desk if you experience further issues.
Posted Dec 05, 2025 - 08:28 MST

Monitoring

A fix has been applied and TouchNet should be available to all users. We will continue to monitor this closely.
Posted Dec 04, 2025 - 13:50 MST

Identified

We have identified a TouchNet outage affecting students ability to pay tuition. Updates will be provided as we learn more.
Posted Dec 04, 2025 - 11:32 MST
This incident affected: Payments and POS Services (Tuition Payment Services).