Degraded Jira and Confluence Performance

Incident Report for Utah Valley University

Resolved

The degraded performance affecting Atlassian Jira and Confluence has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Apr 24, 2025 - 09:51 MDT

Identified

We have identified reports of degraded performance affecting Atlassian Jira and Confluence. For more information, please refer to the Atlassian status page linked here: https://status.atlassian.com/
Updates will be provided as we learn more.
Posted Apr 23, 2025 - 09:20 MDT
This incident affected: IT Professional Services (Jira Service Management).