faculty.uvu.edu Outage
Incident Report for Utah Valley University
Resolved
The faculty.uvu.edu outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Apr 03, 2024 - 10:11 MDT
Monitoring
A fix has been applied and faculty.uvu.edu should be available. We will continue to monitor it closely.
Posted Apr 02, 2024 - 09:25 MDT
Identified
We have identified an outage affecting faculty.uvu.edu. We are in contact with the vendor. Updates will be provided as we learn more.
Posted Apr 01, 2024 - 16:03 MDT
This incident affected: General IT Services.