Partial UVU Campus Power Outage
Incident Report for Utah Valley University
Resolved
The power outage has been resolved and affected systems are online. Please contact the Service Desk if you experience any more issues.
Posted Jun 27, 2024 - 09:41 MDT
Monitoring
A fix has been applied and power should be available at all locations. Devices are continually coming back online. We will continue to monitor it closely.
Posted Jun 26, 2024 - 16:34 MDT
Investigating
We are investigating reports of a partial campus power outage. Updates will be provided as we learn more.
Posted Jun 26, 2024 - 16:13 MDT
This incident affected: General IT Services.