Get email notifications whenever Utah Valley University creates, updates or resolves an incident.
Get text message notifications whenever Utah Valley University creates or resolves an incident.
Get webhook notifications whenever Utah Valley University creates an incident, updates an incident, resolves an incident or changes a component status.
The network outage affecting the BA and WB buildings has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Feb 17, 2026 - 14:35 MST
Monitoring
A fix has been applied and networking should be available at all locations. We will continue to monitor the network closely.
Posted Feb 17, 2026 - 10:42 MST
Update
Network functionality has been restored to the Browning Administration building. The Woodbury Business building is still affected.
Posted Feb 17, 2026 - 10:10 MST
Update
The network outage is also affecting the Woodbury Business building floor 1.
Posted Feb 17, 2026 - 09:25 MST
Identified
We have identified a wired and wireless network outage affecting Browning Administration floor 1, including BA104 and the surrounding offices. Updates will be provided as we learn more.
Posted Feb 17, 2026 - 09:10 MST
Investigating
We are investigating reports of a network outage on the first floor of the Browning Administration building. Updates will be provided as we learn more.
Posted Feb 17, 2026 - 08:54 MST
This incident affected: Network & Wireless (Wireless Network, Wired Network).