Partial my.uvu.edu Outage
Incident Report for Utah Valley University
Resolved
The my.uvu.edu partial outage affecting logins has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Aug 18, 2021 - 13:44 MDT
Monitoring
A fix has been applied and my.uvu.edu logins should be available. We will continue to monitor my.uvu.edu closely.
Posted Aug 18, 2021 - 13:07 MDT
Identified
We have identified a partial my.uvu.edu outage causing slowness and time out errors when logging in. Updates will be provided as we learn more.
Posted Aug 18, 2021 - 11:38 MDT
This incident affected: myUVU Services (myUVU General Services, myUVU Student Services, myUVU Employee Services) and Accounts & Access (Duo, UVU Accounts).