Online Diploma Ordering Outage
Incident Report for Utah Valley University
Resolved
The online diploma ordering outage has been resolved. Please contact the Service Desk if you experience further issues.
Posted Nov 13, 2024 - 13:17 MST
Monitoring
A fix has been applied, and the online diploma ordering should be available now. We will continue to monitor this service closely.
Posted Nov 13, 2024 - 11:21 MST
Investigating
We are investigating reports of an online diploma ordering outage when attempting to order a reissued diploma on https://uvu.edu/graduation/post-grad
Updates will be provided as we learn more.
Posted Nov 13, 2024 - 10:09 MST