Microsoft Services Performance Degredation

Incident Report for Utah Valley University

Resolved

Microsoft reports their service degradation issue has been resolved. Please contact the Service Desk if you experience further issues.
Posted Jan 23, 2026 - 08:27 MST

Identified

Microsoft is reporting cloud service degradation that may impact Microsoft product performance. Updates will be provided as we learn more.
Posted Jan 22, 2026 - 15:27 MST
This incident affected: Email, Calendar, & Collaboration (Employee Email, Teams) and General IT Services.