Administrative System Outage

Incident Report for Utah Valley University

Resolved

The administrative outage affecting ePAF and Touchnet has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Mar 29, 2023 - 14:42 MDT

Monitoring

A fix has been applied and ePAF submissions should be available to all users. We will continue to monitor ePAF submissions closely. Please contact the Service Desk if you experience any issues.
Posted Mar 28, 2023 - 14:30 MDT

Identified

After investigation we were able to resolve the online payment system outage and have identified an underlining system issue intermittently affecting ePAF submissions. Updates will be provided as we learn more.
Posted Mar 28, 2023 - 10:33 MDT

Investigating

We are investigating reports of an online payment outage. Updates will be provided as we learn more.
Posted Mar 27, 2023 - 09:06 MDT
This incident affected: myUVU Services (myUVU General Services), Payments and POS Services (Tuition Payment Services), and Employee and HR Services (HR and Hiring Services).