Partial myUVU Outage

Incident Report for Utah Valley University

Resolved

The myUVU outage has been resolved. Please contact the Service Desk if you experience any further issues.
Posted May 01, 2025 - 10:18 MDT

Monitoring

A fix has been applied and myUVU should be available to all users. We will continue to monitor myUVU closely.
Posted May 01, 2025 - 07:57 MDT

Investigating

We are investigating reports of various components of myUVU failing to load properly. Updates will be provided as we learn more.
Posted May 01, 2025 - 07:20 MDT
This incident affected: myUVU Services (myUVU Student Services).