Square Point of Sale System Outage
Incident Report for Utah Valley University
Resolved
This incident has been resolved.
Posted Feb 25, 2020 - 16:35 MST
Monitoring
Square has applied a fix and services are being restored. Please contact the Service Desk if you continue to experience issues with your Square point of sale system.
Posted Feb 25, 2020 - 15:54 MST
Identified
Square point of sale systems are experiencing a major outage affecting our ability to receive payments at locations using Square systems. You may need to access an ATM to pay for services using cash at affected locations such as the Testing Center at Wolverine Services.
Posted Feb 25, 2020 - 15:00 MST
This incident affected: General IT Services.