Partial connectivity issue to UVU websites
Incident Report for Utah Valley University
Resolved
The partial connectivity outage to UVU sites affecting some users in and around the Spanish Fork area has been resolved. Please contact the Service Desk if you encounter any further issues. Thank you.
Posted May 03, 2024 - 09:21 MDT
Investigating
We have identified an issue with some internet service providers not allowing users to connect to UVU websites. Updates will be provided as we learn more.
Posted Apr 25, 2024 - 09:14 MDT
This incident affected: myUVU Services (myUVU General Services).