Partial M365 Outage

Incident Report for Utah Valley University

Resolved

The Microsoft 365 outage affecting Outlook and other Microsoft applications, such as SharePoint, Teams, and OneDrive has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Jun 06, 2023 - 09:57 MDT

Identified

We have identified a partial Microsoft 365 outage affecting Outlook and indirectly affecting other Microsoft applications, such as SharePoint, Teams, and OneDrive. Microsoft is aware of this issue and working on it. Updates will be provided as we learn more.
Posted Jun 05, 2023 - 09:53 MDT
This incident affected: Software, Websites & Apps (Office 365).