Investigating - We have identified an issue with some internet service providers not allowing users to connect to UVU websites. Updates will be provided as we learn more.
Apr 25, 2024 - 09:14 MDT
myUVU Services ? Degraded Performance
myUVU General Services ? Degraded Performance
myUVU Student Services ? Operational
myUVU Employee Services ? Operational
Teaching, Learning, & Classrooms ? Operational
Canvas ? Operational
SRI ? Operational
Classroom Streaming Services ? Operational
Audio/Video Support ? Operational
Citrix Virtual Lab ? Operational
Tutor Schedule System ? Operational
Network & Wireless ? Operational
Wireless Network ? Operational
Wired Network ? Operational
Virtual Private Networks ? Operational
Registration and Planning ? Operational
Banner ? Operational
Wolverine Track ? Operational
Advisor Dashboard ? Operational
Class Registration ? Operational
Accounts & Access ? Operational
Duo ? Operational
UVU Accounts ? Operational
Password Management Tools ? Operational
Software, Websites & Apps ? Operational
Google Suite ? Operational
Office 365 ? Operational
Adobe ? Operational
myUVU ? Operational
Employee and HR Services ? Operational
Banner Application Navigator ? Operational
TIMS Employee Time Management ? Operational
HR and Hiring Services ? Operational
Campus Services ? Operational
Printing ? Operational
Power ? Operational
SLSS Services ? Operational
Campus Scheduling Services ? Operational
Email, Calendar, & Collaboration ? Operational
Employee Email ? Operational
Student Gmail ? Operational
Teams ? Operational
Data Reports ? Operational
Atlassian ? Operational
Telephones ? Operational
IT Professional Services ? Operational
IT Asset Management ? Operational
MS Threat Protection ? Operational
Jira Service Management ? Operational
Ask Wilson Chatbot ? Operational
Bitdefender ? Operational
Bitlocker ? Operational
OU Campus ? Operational
Storage, Servers, & Backups ? Operational
Box ? Operational
Virtualization ? Operational
Payments and POS Services ? Operational
Dining and POS Services ? Operational
Tuition Payment Services ? Operational
Financial Aid Services ? Operational
General IT Services ? Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Past Incidents
Apr 26, 2024

No incidents reported today.

Apr 25, 2024

Unresolved incident: Partial connectivity issue to UVU websites.

Apr 24, 2024

No incidents reported.

Apr 23, 2024

No incidents reported.

Apr 22, 2024

No incidents reported.

Apr 21, 2024

No incidents reported.

Apr 20, 2024
Completed - The scheduled maintenance has been completed.
Apr 20, 15:00 MDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 20, 06:00 MDT
Scheduled - System maintenance is scheduled for Saturday, April 20th, from 6 AM to noon.
Some services in myUVU will be unavailable. Canvas is expected to remain available.

The following services may be unavailable during this scheduled maintenance:

Student Services
- Registration and Planning Services
- My Academics Services such as Wolverine Track, Grades, Class List, Degree Information Services
- Paying For My Education Services
Employee Services
- Banner Services
- Payroll and Timeclock
Faculty Services
- Banner Faculty Services
- My Classes Services
Advisor Services
- Advisor Dashboard
- Banner Advisor Services
- Advisor Course Information

Apr 13, 08:10 MDT
Apr 19, 2024

No incidents reported.

Apr 18, 2024
Resolved - The Eduroam Wi-FI outage has been resolved. Please contact the Service Desk if you experience any more issues.
Apr 18, 14:19 MDT
Monitoring - A fix has been applied and Eduroam Wi-Fi should be available to UVU personnel. We will continue to monitor it closely.
Apr 18, 11:00 MDT
Investigating - We are investigating reports of Wi-Fi outages across campus. Updates will be provided as we learn more.
Apr 18, 08:50 MDT
Apr 17, 2024

No incidents reported.

Apr 16, 2024
Resolved - The outage impacting off-campus access to multiple UVU sites has been resolved. Please contact the Service Desk if you experience further issues.
Apr 16, 15:56 MDT
Monitoring - A fix has been applied for the issue affecting off-campus access to multiple uvu.edu sites and all service has been restored. We will continue to monitor.
Apr 16, 13:36 MDT
Identified - We have identified a major outage affecting off-campus access to several UVU websites. On-campus access is not impacted. Updates will be provided as they become available.
Apr 16, 13:08 MDT
Investigating - We are investigating reports of UVU Website outages off-campus. Updates will be provided as we learn more.
Apr 16, 12:54 MDT
Apr 15, 2024
Resolved - The network outage affecting the AX building has been resolved. Please contact the Service Desk if you experience any more issues.
Apr 15, 16:31 MDT
Monitoring - A fix has been applied and the network should be available at the AX building. We will continue to monitor it closely.
Apr 15, 16:02 MDT
Identified - We have identified a partial network outage affecting the AX building. Updates will be provided as we learn more.
Apr 15, 09:39 MDT
Apr 14, 2024

No incidents reported.

Apr 13, 2024

No incidents reported.

Apr 12, 2024

No incidents reported.