Partial MyUVU Outage

Incident Report for Utah Valley University

Resolved

The MyUVU outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Oct 25, 2024 - 13:54 MDT

Monitoring

A fix has been applied and MyUVU should be available to all users. We will continue to monitor MyUVU closely.
Posted Oct 25, 2024 - 10:14 MDT

Investigating

We are investigating reports of a MyUVU outage, which is preventing users from logging in. We will provide updates as we learn more.
Posted Oct 25, 2024 - 09:15 MDT
This incident affected: myUVU Services (myUVU General Services) and Accounts & Access (UVU Accounts).