Partial Microsoft 365 Outage
Incident Report for Utah Valley University
Resolved
This outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Oct 16, 2024 - 17:06 MDT
Monitoring
A fix has been applied and Office 365 should now be available for all users to login. We will continue to monitor this service closely.
Posted Oct 16, 2024 - 15:00 MDT
Identified
We have identified an issue that is preventing some users from logging into Microsoft 365. The resolution of this issue is subject to Microsoft's update schedule and may take up to 24 hours. We will provide updates as we receive more information.
Posted Oct 16, 2024 - 14:04 MDT
Investigating
We are investigating reports of an issue preventing some users from logging into various Microsoft products, including Outlook and Teams. Updates will be provided as we learn more.
Posted Oct 16, 2024 - 13:35 MDT
This incident affected: myUVU Services (myUVU General Services, myUVU Student Services, myUVU Employee Services), Software, Websites & Apps (Office 365), and Email, Calendar, & Collaboration (Teams).