DegreeWorks Outage

Incident Report for Utah Valley University

Resolved

The DegreeWorks outage has been resolved. Please contact the Service Desk if you encounter any further issues.
Posted Jan 27, 2025 - 12:14 MST

Monitoring

A fix has been applied and DegreeWorks is functioning as expected. We will continue to monitor DegreeWorks closely.
Posted Jan 27, 2025 - 08:59 MST

Investigating

We are investigating reports of a DegreeWorks outage. Updates will be provided as we learn more.
Posted Jan 27, 2025 - 08:29 MST
This incident affected: Registration and Planning (Banner) and myUVU Services (myUVU Student Services).