Multiple Services Outage

Incident Report for Utah Valley University

Resolved

The Banner, TIMS, MyUVU, Wolverine Track, and other services outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Apr 18, 2025 - 13:51 MDT

Monitoring

A fix has been applied and Banner, TIMS, MyUVU, Wolverine Track, and other services should be available. We will continue to monitor the services closely.
Posted Apr 18, 2025 - 09:50 MDT

Investigating

We are investigating reports of an outage affecting Banner, TIMS, MyUVU, Wolverine Track, and other services. Updates will be provided as we learn more.
Posted Apr 18, 2025 - 07:23 MDT
This incident affected: myUVU Services (myUVU General Services, myUVU Student Services), Registration and Planning (Banner, Wolverine Track, Class Registration), and Employee and HR Services (TIMS Employee Time Management).