Power Outage
Incident Report for Utah Valley University
Resolved
The power outage affecting the Fulton Library has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Apr 11, 2023 - 10:50 MDT
Monitoring
A fix has been applied and power should be available at the Fulton Library. We will continue to monitor the power closely.
Posted Apr 11, 2023 - 09:57 MDT
Identified
We have identified a power outage affecting the Fulton Library. Updates will be provided as we learn more.
Posted Apr 11, 2023 - 09:44 MDT
This incident affected: Campus Services (Power).