Wolverine Track Known Bug
Incident Report for Utah Valley University
Resolved
This incident has been resolved. Please contact the Service Desk if you continue to experience issues in Wolverine Track.
Posted Jun 01, 2020 - 09:30 MDT
Monitoring
There is a known bug affecting some features in Wolverine Track. If you are experiencing issues with GPA Calc, Dashboard Notes, Petitions, or Admin tabs, please use Firefox or Edge web browsers as a workaround. We are working with the vendor to resolve this issue. An update will be provided when we know more.
Posted May 29, 2020 - 17:20 MDT
This incident affected: Software & Apps (Student Software).