Scholarship Universe Degraded Performance

Incident Report for Utah Valley University

Resolved

The Scholarship Universe outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Jun 30, 2025 - 10:57 MDT

Monitoring

A fix has been applied and Scholarship Universe should be functioning as expected. We will continue to monitor Scholarship Universe closely.
Posted Jun 27, 2025 - 13:06 MDT

Update

We are continuing to investigate this issue.
Posted Jun 27, 2025 - 13:05 MDT

Investigating

We are investigating reports of degraded performance related to Scholarship Universe. Updates will be provided as we learn more.
Posted Jun 27, 2025 - 12:55 MDT
This incident affected: General IT Services.