Multiple UVU Services Outage

Incident Report for Utah Valley University

Monitoring

A fix has been applied by Microsoft and any affected services should be available to all users. We will continue to monitor affected services closely.
Posted Jul 23, 2026 - 15:20 MDT

Identified

We have identified a Microsoft Azure outage as the source of several UVU services being unavailable. A fix has been applied, and functionality is continuing to be restored.

Updates will be provided as services become available.
Posted Jul 23, 2026 - 13:14 MDT

Update

We are investigating reports of additional outages for the following services:

SIRA
Graduation Application
Major Change
Banner

Updates will be provided as we learn more.
Posted Jul 23, 2026 - 10:31 MDT

Investigating

We are investigating reports of a Scholarship Universe and Student Forms outage. Updates will be provided as we learn more.
Posted Jul 23, 2026 - 09:30 MDT
This incident affects: Registration and Planning (Banner), myUVU Services (myUVU Student Services), and General IT Services.