myUVU link issues
Incident Report for Utah Valley University
Resolved
All myUVU links have been repaired. Please contact the Service Desk if you continue to experience issues.
Posted Jul 20, 2020 - 10:19 MDT
Monitoring
All myUVU links have been repaired, and we are monitoring their effectiveness closely. Please contact the Service Desk if you continue to experience issues.
Posted Jul 20, 2020 - 09:39 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 20, 2020 - 08:14 MDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 20, 2020 - 08:06 MDT
Identified
There are a number of links in myUVU that are currently not functional. We are working to resolve this as soon as possible.
Posted Jul 20, 2020 - 08:02 MDT
This incident affected: Software, Websites & Apps (myUVU).