Partial Internet Outage on Lehi Campus

Incident Report for Utah Valley University

Resolved

The partial Internet outage affecting the Lehi campus has been resolved. Please contact the Service Desk if you experience further issues.
Posted Jun 12, 2025 - 09:09 MDT

Monitoring

A fix has been applied and Wired and Wireless internet should now be available on Lehi campus. We will continue to monitor this service closely.
Posted Jun 11, 2025 - 15:53 MDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 11, 2025 - 15:52 MDT

Identified

We have identified a partial Internet outage affecting the Lehi campus. Updates will be provided as we learn more.
Posted Jun 11, 2025 - 15:21 MDT
This incident affected: Network & Wireless (Wireless Network, Wired Network).