Student Financial Responsibility Agreement Outage

Incident Report for Utah Valley University

Resolved

The Student Financial Responsibility Agreement outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Jul 23, 2026 - 17:01 MDT

Monitoring

A fix has been applied and the Student Financial Responsibility Agreement form should be available for all users. We will continue to monitor it closely.
Posted Jul 23, 2026 - 15:15 MDT

Identified

We have identified a Student Financial Responsibility Agreement outage affecting all students attempting to access the form. Updates will be provided as we learn more.
Posted Jul 23, 2026 - 11:52 MDT
This incident affected: myUVU Services (myUVU Student Services).