Partial Power Outage
Incident Report for Utah Valley University
Resolved
The Power outage affecting Network services has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Oct 07, 2022 - 13:41 MDT
Monitoring
A fix has been applied and all UVU campus power should be available on campus. We will continue to monitor UVU campus power closely.
Posted Oct 06, 2022 - 14:20 MDT
Investigating
We are investigating reports of power outages affecting networking and other services. Updates will be provided as we learn more.
Posted Oct 06, 2022 - 12:08 MDT
This incident affected: Campus Services (Power).