Login to my.uvu.edu unavailable
Incident Report for Utah Valley University
Resolved
This incident has been resolved.
Posted Feb 05, 2020 - 18:16 MST
Monitoring
A fix has been applied. Please contact the Service Desk if you continue to experience any issues.
Posted Feb 05, 2020 - 17:53 MST
Investigating
Login for my.uvu.edu is currently unavailable. It is being looked into. An update will be provided when we learn more.
Posted Feb 05, 2020 - 17:43 MST
This incident affected: myUVU Services (myUVU General Services, myUVU Student Services, myUVU Employee Services).