Utah Valley University - StatusPage

UVU Login Page

Incident Report for Utah Valley University

Resolved

The myUVU login page issue has been resolved. Please contact the Service Desk if you experience any more issues.
Posted 2 years ago. Mar 31, 2023 - 16:39 MDT

Monitoring

A fix has been applied and the myUVU login page should be available to all users. We will continue to monitor the myUVU login page closely.
Posted 2 years ago. Mar 31, 2023 - 08:49 MDT

Investigating

We are currently investigating an error with the UVU login page. Users should be able to log in as usual. Please reach out to service desk if you experience any issues.
Posted 2 years ago. Mar 31, 2023 - 07:45 MDT
This incident affected: myUVU Services (myUVU General Services).