Utah Valley University - StatusPage

my.uvu.edu Outage

Incident Report for Utah Valley University

Resolved

The my.uvu.edu outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted 10 months ago. Jul 19, 2024 - 04:19 MDT

Monitoring

A fix has been applied and my.uvu.edu should be available to all users. We will continue to monitor my.uvu.edu closely.
Posted 10 months ago. Jul 19, 2024 - 01:48 MDT

Investigating

We are investigating reports of a my.uvu.edu outage. Updates will be provided as we learn more.
Posted 10 months ago. Jul 19, 2024 - 01:22 MDT
This incident affected: myUVU Services (myUVU General Services, myUVU Student Services, myUVU Employee Services).