Microsoft Teams Login Issue
Incident Report for Utah Valley University
Resolved
This incident has been resolved.
Posted Feb 03, 2020 - 13:02 MST
Monitoring
Microsoft has deployed a fix. Please contact the Service Desk if you continue to experience issues logging into Microsoft Teams.
Posted Feb 03, 2020 - 09:44 MST
Identified
Microsoft has identified an issue affecting login to Microsoft Teams. Microsoft is developing a fix. An update will be provided when we learn more.
Posted Feb 03, 2020 - 08:45 MST