Partial Power Outage
Incident Report for Utah Valley University
Resolved
The partial power outage affecting network services at Starbucks has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Aug 18, 2022 - 08:36 MDT
Identified
We have identified a partial power outage affecting Network services at Starbucks. Updates will be provided as we learn more.
Posted Aug 17, 2022 - 17:04 MDT
This incident affected: Network & Wireless (Wired Network).