TIMS Outage

Incident Report for Utah Valley University

Resolved

The TIMS outage employees has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Sep 01, 2026 - 16:48 MDT

Identified

We have identified a TIMS outage affecting employees. Updates will be provided as we learn more.
Posted Sep 01, 2026 - 15:46 MDT

Investigating

We are investigating reports of a TIMS outage. Updates will be provided as we learn more.
Posted Sep 01, 2026 - 13:24 MDT
This incident affected: myUVU Services (myUVU Employee Services).