Late Payment Fees Issued Earlier Than Scheduled
Incident Report for Utah Valley University
Resolved
The issue with late payment fees being charged ahead of schedule has been resolved. The collections office has removed the late fees for the affected parties. Please contact the Service Desk if you experience further issues.
Posted Sep 12, 2024 - 11:49 MDT
Investigating
We are investigating reports indicating that students have been charged late payment fees ahead of the scheduled time. Students who pay their original balance, excluding the late fee, by the end of today will not risk having their classes dropped. For additional assistance, please contact the Service Desk.
Posted Sep 12, 2024 - 08:50 MDT