Wasatch Campus Power Outage
Incident Report for Utah Valley University
Resolved
The partial network outage affecting the automotive area of the Wasatch campus has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Jun 24, 2021 - 11:08 MDT
Update
Power has been restored to the Wasatch campus but it is still experiencing a partial network outage. Updates will be provided as we learn more.
Posted Jun 23, 2021 - 13:29 MDT
Identified
Rocky Mountain Power is working to restore power and estimates it should be restored before 4:30 p.m. Updates will be provided as we learn more.
Posted Jun 23, 2021 - 12:30 MDT
Investigating
We are investigating reports of a power outage at the Wasatch campus. Updates will be provided as we learn more.
Posted Jun 23, 2021 - 11:40 MDT
This incident affected: Network & Wireless (Wireless Network, Wired Network).