Partial network outage in Wolverine Services building
Incident Report for Utah Valley University
Resolved
This incident has been resolved.
Posted Mar 12, 2020 - 17:12 MDT
Investigating
We are looking into a partial network outage in the Wolverine Services building and will update when we have more information.
Posted Mar 12, 2020 - 16:53 MDT
This incident affected: General IT Services.