UVU.jobs Outage
Incident Report for Utah Valley University
Resolved
The uvu.jobs outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Mar 22, 2023 - 15:50 MDT
Investigating
We are investigating reports of a uvu.jobs portal outage. Updates will be provided as we learn more.
Posted Mar 22, 2023 - 09:42 MDT
This incident affected: Employee and HR Services (HR and Hiring Services).