Tuition Payment Outage

Incident Report for Utah Valley University

Resolved

The Touchnet outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Aug 06, 2025 - 09:09 MDT

Monitoring

A fix has been applied and Touchnet should be available to all users. We will continue to monitor Touchnet closely.
Posted Aug 05, 2025 - 20:53 MDT

Investigating

We are investigating reports of a Touchnet outage affecting the ability for students to pay tuition. Updates will be provided as we learn more.
Posted Aug 05, 2025 - 16:40 MDT
This incident affected: Payments and POS Services (Tuition Payment Services).