Partial Office 365 Outage
Incident Report for Utah Valley University
Resolved
The Office 365 suite outage has been resolved. Please contact the Service Desk if you experience any more issues.
Posted Apr 20, 2023 - 14:23 MDT
Identified
We have identified a partial Office 365 suite outage affecting all users. Microsoft is aware of this issue and working on it. Updates will be provided as we learn more.
Posted Apr 20, 2023 - 09:34 MDT
This incident affected: Software, Websites & Apps (Office 365).